Maj 092012
 

Flattr this!

En av utvecklarna av Calligra blev litet sur över min recension av Calligra Words. Särskilt mitt påstående om att Words drar in ett par hundra MB beroenden i en icke-KDE miljö:

 

Eftersom det är ett KDE-program fungerar det bäst i den miljön. I Gnome drar man in ett par hundra MB KDE-beroenden.

 

RAM och Hårddiskutrymme

Jag borde kanske ha uttryckt mig tydligare och en del av meningen försvann i översättningen till engelska. Jag avsåg paketberoenden som följer med vid installation av Words utanför KDE. Det vill säga hårddiskutrymme. Bloggaren tolkade det som att jag avsåg avtryck i RAM-minnet.

KDE-program fungerar lika bra i Gnome eller andra skrivbordsmiljöer som i KDE. Jag har aldrig störts av eller ens tänkt på att de slukar RAM-minne och de fynd som bloggaren gör att de drar under 50MB stämmer säkert. Eftersom RAM-minne räknas i GB är detta en låg siffra.

Då missförståndet är utrett blev jag litet nyfiken, hur mycket diskutrymme kräver Words i olika skrivbordsmiljöer?

 

Kubuntu

I Kubuntu 12.04 kräver Words knappt 36MB hårddiskutrymme. Detta inkluderar svenska språkfiler, samma som i alla installationer nedan. Det är fullt rimligt för ett kompetent ordbehandlingsprogram.

 

I Kubuntu är alla KDE-beroenden på plats och att installera Words kräver inte mycket plats (notera att bilden är tagen i Synaptic, ett GTK-program som dragit in en massa GTK-beroenden. Bilden blev mer pedagogisk i Synaptic jämfört med Muon...)

 

Ubuntu

I min lilla experimentinstallation av Ubuntu 12.04 behöver Calligra Words 328MB diskutrymme. Detta är siffran jag avsåg och siffran är i själva verket högre än vad jag skrev i recensionen.

 

I Ubuntu drar man ner en massa KDE-beroenden (125) och installationen av Words blir nästan tio gånger så stor som i Kubuntu...

 

Som en jämförelse kräver AbiWord drygt 31MB diskutrymme, litet mindre än Words i Kubuntu.

 

Som en jämförelse behöver AbiWord bara drygt 31MB diskutrymme

 

AbiWord har litet färre funktioner än Words så denna siffra är också helt acceptabel.

KDE-program har många gemensamma bibliotek och om man installerar hela Calligra kontorspaket tar det 494MB diskutrymme, vilket är mindre än om man installerar hela LibreOffice.

 

Hela Calligra Office behöver knappt 500MB diskutrymme

 

Den som vill ha mycket funktion per MB hårddisk bör därför installera hela Calligra. Om man installerar ytterligare KDE-program sjunker andelen KDE-beroenden och om man tar bort motsvarande GTK-program är det frågan om ens samlade program behöver större utrymme.

 

Hårddiskutrymme…

Diskutrymme och stora programinstallationer kan för en vanlig användare vara viktigt i främst två lägen:

  1. Om man har en liten hårddisk
  2. Om man har en långsam Internetuppkoppling och har svårt att ladda ner paket

Moderna datorer har enorma hårddiskar och i Sverige har de flesta tillgång till snabbt Internet på ett eller annat sätt. För de flesta finns därför inget giltigt skäl att inte använda Calligra Words.

Jag tycker att diskussionen om KDE/QT kontra GNOME/GTK i Linux är överspelad. Båda typerna av program fungerar som regel utmärkt oavsett skrivbordsmiljö och är tillräckligt snygga. Några hundra MB extra systemfiler är sällan ett problem och är underordnat att använda sina favoritprogram. Skulle jag börja använda Ubuntu igen skulle jag ha svårt att vara utan Kile, Okular och K3b och jag har Synaptic installerat i Kubuntu.

Kanske lät jag därför frågan om hårddiskutrymme få för stort utrymme i recensionen och i denna uppföljare.

 

Åter till Words!

Det bästa bloggaren skriver är att många av de buggar jag råkade ut för i Calligra Words håller på att åtgärdas. Även om Words i dagsläget inte är riktigt färdigt tror jag att det relativt snabbt kan bli ett mycket gångbart alternativ. Jag har det fortfarande installerat och använder det nästan dagligen. Dessutom kommer jag att testa fler av Calligraprogrammen!

  3 Responses to “Minne i Calligra Words”

  1. Hej Påvel!

    Jag blev definitivt inte sur över recensionen, snarare glad för du skrev ju en massa bra saker om min lilla baby. 🙂 Att det dessutom finns några problem är ju bara att erkänna och sedan sätta sig ner och fixa dem.

    Men däremot blev jag nyfiken. Det där med att ”KDE-program drar mycket minne” är ju en seglivad myt. Så jag bestämde mig för att jag skulle försöka reda ut hur mycket overhead det egentligen handlade om.

    Sen fick jag påpekat att det nog egentligen handlade om diskutrymme och när jag läste det igen så verkade det ju faktiskt så. Men när jag ser dina siffror här ovan så blir jag nyfiken igen. Det skulle verkligen vara jätteintressant att få reda på vilka 125 paket som Ubuntu vill dra in som beroenden. 125 verkar vara alldeles för mycket. Jag är säker på att man genom att paketera lite smartare skulle kunna få ner det där ganska rejält.

    • Hej Inge!
      Tack för ditt arbete med Calligra!

      Jag borde kanske aktivera mig som buggrapportör för Words eftersom jag använder det ganska avancerat och kritiskt. Ska se om jag lyckas förstå hur ni är organiserade!

      Det är onekligen ett stort antal paket som dras in i Ubuntu. Installationen är gjord på enklaste sättet i synaptic genom att markera calligrawords och det svenska språkpaketet. Det är fullt möjligt att en del av paketen kan tas bort i efterhand utan att något händer. Här är listan:

      akonadi-backend-mysql (version 1.7.2-0ubuntu1) kommer att installeras
      akonadi-server (version 1.7.2-0ubuntu1) kommer att installeras
      calligra-data (version 1:2.4.0-0ubuntu2) kommer att installeras
      calligra-l10n-sv (version 1:2.4.0-0ubuntu3) kommer att installeras
      calligra-libs (version 1:2.4.0-0ubuntu2) kommer att installeras
      calligrawords (version 1:2.4.0-0ubuntu2) kommer att installeras
      calligrawords-data (version 1:2.4.0-0ubuntu2) kommer att installeras
      docbook-xsl (version 1.76.1+dfsg-1ubuntu1) kommer att installeras
      icoutils (version 0.29.1-2) kommer att installeras
      kate-data (version 4:4.8.2-0ubuntu2) kommer att installeras
      katepart (version 4:4.8.2-0ubuntu2) kommer att installeras
      kde-l10n-sv (version 4:4.8.2-0ubuntu2) kommer att installeras
      kde-runtime (version 4:4.8.2-0ubuntu2) kommer att installeras
      kde-runtime-data (version 4:4.8.2-0ubuntu2) kommer att installeras
      kdelibs-bin (version 4:4.8.2-0ubuntu1) kommer att installeras
      kdelibs5-data (version 4:4.8.2-0ubuntu1) kommer att installeras
      kdelibs5-plugins (version 4:4.8.2-0ubuntu1) kommer att installeras
      kdepim-runtime (version 4:4.8.2a-0ubuntu2) kommer att installeras
      kdepimlibs-kio-plugins (version 4:4.8.2-0ubuntu2) kommer att installeras
      kdoctools (version 4:4.8.2-0ubuntu1) kommer att installeras
      kubuntu-debug-installer (version 11.10ubuntu1) kommer att installeras
      language-pack-kde-sv (version 1:12.04+20120417) kommer att installeras
      language-pack-kde-sv-base (version 1:12.04+20120417) kommer att installeras
      libakonadi-calendar4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libakonadi-contact4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libakonadi-kabc4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libakonadi-kcal4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libakonadi-kde4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libakonadi-kmime4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libakonadi-notes4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libakonadiprotocolinternals1 (version 1.7.2-0ubuntu1) kommer att installeras
      libattica0.3 (version 0.3.0-0ubuntu2) kommer att installeras
      libboost-program-options1.46.1 (version 1.46.1-7ubuntu3) kommer att installeras
      libclucene0ldbl (version 0.9.21b-2) kommer att installeras
      libdlrestrictions1 (version 0.14.2ubuntu5) kommer att installeras
      libdmtx0a (version 0.7.2-1build2) kommer att installeras
      libkabc4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libkalarmcal2 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libkatepartinterfaces4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libkcal4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libkcalcore4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libkcalutils4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libkcmutils4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkde3support4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkdeclarative5 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkdecore5 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkdesu5 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkdeui5 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkdewebkit5 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkdnssd4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkemoticons4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkfile4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkholidays4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libkhtml5 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkidletime4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkimap4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libkio5 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkjsapi4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkjsembed4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkldap4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libkmbox4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libkmediaplayer4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkmime4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libknewstuff3-4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libknotifyconfig4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkntlm4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkparts4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkpimidentities4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libkpimtextedit4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libkpimutils4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libkpty4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkresources4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libkrosscore4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libkrossui4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libktexteditor4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libmailtransport4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libmicroblog4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libmysqlclient18 (version 5.5.22-0ubuntu1) kommer att installeras
      libnepomuk4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libnepomukdatamanagement4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libnepomukquery4a (version 4:4.8.2-0ubuntu1) kommer att installeras
      libnepomuksync4 (version 4:4.8.2-0ubuntu2) kommer att installeras
      libnepomukutils4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libntrack-qt4-1 (version 016-1ubuntu1) kommer att installeras
      libntrack0 (version 016-1ubuntu1) kommer att installeras
      libphonon4 (version 4:4.7.0really4.6.0-0ubuntu1) kommer att installeras
      libplasma3 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libpolkit-qt-1-1 (version 0.103.0-1) kommer att installeras
      libprison0 (version 1.0+dfsg-1) kommer att installeras
      libqapt-runtime (version 1.3.1-0ubuntu2) kommer att installeras
      libqapt1 (version 1.3.1-0ubuntu2) kommer att installeras
      libqca2 (version 2.0.3-2) kommer att installeras
      libqrencode3 (version 3.1.1-1ubuntu1) kommer att installeras
      libqt4-designer (version 4:4.8.1-0ubuntu4.1) kommer att installeras
      libqt4-qt3support (version 4:4.8.1-0ubuntu4.1) kommer att installeras
      libqt4-sql-mysql (version 4:4.8.1-0ubuntu4.1) kommer att installeras
      libqtwebkit4 (version 2.2.1-1ubuntu4) kommer att installeras
      libreadline5 (version 5.2-11) kommer att installeras
      libruby1.8 (version 1.8.7.352-2ubuntu1) kommer att installeras
      libsolid4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libsoprano4 (version 2.7.5+dfsg.1-0ubuntu1) kommer att installeras
      libspnav0 (version 0.2.2-1ubuntu1) kommer att installeras
      libstreamanalyzer0 (version 0.7.7-1.1ubuntu3) kommer att installeras
      libstreams0 (version 0.7.7-1.1ubuntu3) kommer att installeras
      libthreadweaver4 (version 4:4.8.2-0ubuntu1) kommer att installeras
      libvirtodbc0 (version 6.1.4+dfsg1-0ubuntu1) kommer att installeras
      libxml2-utils (version 2.7.8.dfsg-5.1ubuntu4) kommer att installeras
      mysql-client-core-5.5 (version 5.5.22-0ubuntu1) kommer att installeras
      mysql-common (version 5.5.22-0ubuntu1) kommer att installeras
      mysql-server-core-5.5 (version 5.5.22-0ubuntu1) kommer att installeras
      ntrack-module-libnl-0 (version 016-1ubuntu1) kommer att installeras
      odbcinst (version 2.2.14p2-5ubuntu3) kommer att installeras
      odbcinst1debian2 (version 2.2.14p2-5ubuntu3) kommer att installeras
      oxygen-icon-theme (version 4:4.8.2-0ubuntu1) kommer att installeras
      phonon (version 4:4.7.0really4.6.0-0ubuntu1) kommer att installeras
      phonon-backend-gstreamer (version 4:4.7.0really4.6.0-0ubuntu1) kommer att installeras
      plasma-scriptengine-javascript (version 4:4.8.2-0ubuntu2) kommer att installeras
      qapt-batch (version 1.3.1-0ubuntu2) kommer att installeras
      ruby (version 4.8) kommer att installeras
      ruby1.8 (version 1.8.7.352-2ubuntu1) kommer att installeras
      shared-desktop-ontologies (version 0.8.1-1) kommer att installeras
      soprano-daemon (version 2.7.5+dfsg.1-0ubuntu1) kommer att installeras
      virtuoso-minimal (version 6.1.4+dfsg1-0ubuntu1) kommer att installeras
      virtuoso-opensource-6.1-bin (version 6.1.4+dfsg1-0ubuntu1) kommer att installeras
      virtuoso-opensource-6.1-common (version 6.1.4+dfsg1-0ubuntu1) kommer att installeras

  2. Hej Påvel

    Jeg er Words maintaineren, ock från Danmark så det går bra att forstå svenska. Jag villa gerne säga tack for en mycket balanceret recension. Som Inge säger i bloggen så vil vi ordna problemerne. Til eksempel har jag allerede en patch for ‘flicker’ når man skrivar på den lästa sidan.

    Hoppas du forstår mit dansk – svenska.

Kommentera

%d bloggare gillar detta: